Twitch Security Incident

Incident Report for Live Video Cloud

Resolved

This incident has been resolved.
Posted Oct 07, 2021 - 13:54 UTC

Investigating

Hello,

As the result of Twitch Security Incident (https://blog.twitch.tv/en/2021/10/06/updates-on-the-twitch-security-incident/) API tokens used for Twitch integration may have been compromised.
Actions we are taking to mitigate the issue:

We are changing our internal API keys for Twitch that were exposed in security breach to prevent unauthorized access.

What you have to do:

* Schedule, if you are using Twitch targets in Schedule, please get in touch with LTN Support to plan a Instance security Update. Stream targets have to be re-authenticated as soon as possible. If you are using non API Integrations for Twitch, create new RTMP endpoints in Twitch and update the push targets in Schedule.

* Live Video Cloud, please re-authenticate your twitch.tv account within the Team -> Connected Accounts. If you are using static RTMP Credentials, please update your RTMP Targets with a new twitch.tv Streamkey.


If you are not using Twitch your system is not affected and if you will add Twitch targets in the future these will already use new API tokens.
Posted Oct 07, 2021 - 10:00 UTC
This incident affected: API.